Dell. Force10. Reset password

Релакс, тейк іт ізі!


  1. Підключаємося через minicom;
  2. Вимикаємо і вмикаємо всі модулі живлення;
  3. Чекаємо, поки з’явиться повідомлення “Hit Esc key to interrupt autoboot: 5” і жмемо Esc, щоб зайти в Boot Loader (uBoot);
  4. Для того, щоб ігнорувати startup-config, вводимо: setenv stconfigignore true (uBoot);
  5. Зберігаємо зміни: saveenv (uBoot);
  6. Продовжуємо завантаження системи: boot (uBoot);
  7. В конфігурації за замовчуванням аутентифікацію відключено;
  8. Переходимо в EXEC-mode: en (FTOS command line);
  9. Завантажуємо startup-config: copy startup-config running-config (FTOS command line);
  10. Тепер можна додати нового користувача або змінити дані старого;
  11. Зберігаємо конфігурацію: copy running-config startup-config (FTOS command line);
  12. Перезавантажуємо комутатор для перевірки: reload (FTOS command line);

Пишуть люди


Dell. Force10 S4810. Initial Configuration

Робимо з потиканого дела дєвочку невинну. А потім вже досвідчену. І не дєвочку.


1. Clearing the Current Configuration on switch:
Force10>
Force10>enable
Force10#delete startup-config
Proceed to delete startup-config [confirm yes/no]yes
Force10#reload
System configuration has been modified. Save? [yes/no]no
Proceed with reload [confirm yes/no]yes

2. Disable Jumpstart Mode and set normal boot mode:
Jumpstart-mode
Jumpstart (BMP) mode is the default boot mode configured for a new switch arriving from Dell Force10. This mode obtains the FTOS image and configuration file from a network source (DHCP server and file server).
When the force10 is reloaded it always starts with thtis image if its not disabled, as I found after setting a few parameters and having to end my afternoon at work with a reset switch.

FTOS# reload-type normal-reload

3. Upgrade the FTOS and Uboot Version:
#Upgrade system ftp: A:
Address or name of remote host []: 192.168.176.60
Source file name []: FTOS-SE-9.1.0.0.bin
User name to login remote host: force10
Password to login remote host:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Erasing Sseries Primary Image, please wait

4. Setting the switch hostname, and date and time:
First we can set the hostname, which appears in prompts at the keyboard, and the timezone and corresponding time and date in the software clock, and then send that information to the hardware clock (“calendar”) so that it survives a re-boot.
Note added later: setting a hostname can be misleading within a stack. If the switch becomes part of a stack, not the master, then it adopts the hostname of the stack master, and this is written into the startup-config file and thus retained even if the power is removed from the switch, the stacking cable removed, and then power restored. This could be a bug (as of version 8.3.10.2). Consequently where switches might be stacked, it could be more sense not to set a hostname, but to rely on the stack-unit number (visible in the first page of show running-config), or the assigned management IP address, as a means of verification of which switch you are managing. Alternatively, keep a back-up of the original configuration, see later section, so that it can be restored if de-stacked.

> enable
# config
(conf)# hostname mychosenname
(conf)# clock timezone UTC 0
(conf)# exit
# clock set hh:mm:ss dd month yyyy
# clock update-calendar
# show clock
# show calendar
# write mem

5. Disable Logging:
Disable all logging except on the console: no logging
Disable logging to the logging buffer: no logging buffer CONFIGURATION
Disable logging to terminal lines: no logging monitor CONFIGURATION
Disable console logging: no logging console CONFIGURATION

6. Stacking preliminaries:
If a particular S4810 might be part of a stack, sooner or later, some preliminary settings are best done now. You can set the stack-number to some value 0-11, in place of the stand-alone default of 0. This avoids the stack master dynamically re-assigning the stack-number of a joined stack-member if there is a number conflict/clash. If the switches have some sort of external label number anyway, this would be a good choice, so for my switch number 3:

# show system stack-unit 0
# stack-unit 0 renumber 3
(prompts and reboots)
# show system stack-unit 3
# show system brief

NOTE: changing the stack-unit number causes a reload of the firmware, ie after the renumber command above, even if the switch is currently standalone!
NOTE: the stack-unit number appears to be recorded in flash memory in a hidden location, and not in the startup-config file.

7. Enable SSH:
ip ssh server enable
ip ssh server version 2

8. Configuring an IP address on the management ethernet port:
The management ethernet port is located below the console RJ45 port. It supports 100Mb/s connections (and probably others). I needed to configure it so that I could download new software, and so that I could later remotely login to the switch via a connection to that port. So it needed to be configured with an IP address and to be cabled to the corresponding network. The IP address and network can of course be any network suitable for administration: not necessarily related to the network handled by the switch. Here’s an example with a slot-number of 3 (see previous section about slot-numbers):

# enable
# config
(conf)# interface man 0/0
(conf-if-ma-3/0)# ip address a.b.c.d/24
(conf-if-ma-3/0)# show config
(conf-if-ma-3/0)# exit
(conf)# exit
# write mem (or reload, and reply yes to Save question)


Пишуть люди


Dell. Configuring LACP between OpenIndiana and a Dell Force10 switch

Link aggregation is a method of bundling interfaces together to act as one for increased bandwith and/or failover. One of most used protocols, next to a couple of proprietary ones, for controlling such a channel bond is LACP, the Link Aggregation Control Protocol.

1. Configuring LACP on Dell S4810

Let’s assume, we want to bond two 10G Ethernet ports together, namely TenGigabitEthernet 0/32 and TenGigabitEthernet 0/33

S4810(conf)#interface range tengigabitethernet 0/32 , tengigabitethernet 0/33
S4810(conf-if-range-te-0/32,te-0/33)#port-channel-protocol LACP
S4810(conf-if-range-te-0/32,te-0/33-lacp)#  port-channel 9 mode active
S4810(conf-if-range-te-0/32,te-0/33-lacp)#show conf
!
interface TenGigabitEthernet 0/32
description po9 uplink to Server47
no ip address
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 9 mode active
no shutdown
!
interface TenGigabitEthernet 0/33
description po9 uplink to Server47
no ip address
flowcontrol rx on tx off
!
port-channel-protocol LACP
port-channel 9 mode active
no shutdown

Next, the port-channel interface needs to be configured as layer 2 port and activated afterwards:
S4810(conf)#interface port-channel 9
S4810(conf-if-po-9)#description Uplink to Server47
S4810(conf-if-po-9)#switchport
S4810(conf-if-po-9)#no shutdown
S4810(conf-if-po-9)#show config
!
interface Port-channel 9
description Uplink to Server47
no ip address
switchport
no shutdown

It’s always good practice to also change the description. Depending on your configuration, you might want to change the vlan settings for this newly created port-channel as well:
S4810(conf)#interface vlan 11
S4810(conf-if-vl-11)#untagged port-channel 9
S4810(conf-if-vl-11)#show config
!
interface Vlan 11
description VLAN11-LAN
ip address 10.11.1.10/16
tagged TenGigabitEthernet 0/8-13
tagged Port-channel 1-5,11,13-14
untagged TenGigabitEthernet 0/14,19-20,23,38,46
untagged Port-channel 9
ip helper-address 10.10.10.1
no shutdown

Of course, depending on the actual network topology, your mileage might vary here.
Note that the port-channel will stay in a ‘down’ state until it can exchange LACPDUs with the remote end:
S4810(conf)#do show interfaces port-channel 9 brief
Codes: L - LACP Port-channel
LAG  Mode  Status       Uptime      Ports
L   9    L2L3  down         00:00:00

2. Configuring LACP on OpenIndiana

First, disable the NWAM (Network Auto Magic) service:

1
2
# svcadm disable svc:/network/physical:nwam
# svcadm enable svc:/network/physical:default

To list the available physical ports, use dladm

1
2
3
4
5
6
7
8
root@Server47:~# dladm show-phys
LINK         MEDIA                STATE      SPEED  DUPLEX    DEVICE
myri10ge1    Ethernet             down       10000  full      myri10ge1
myri10ge0    Ethernet             down       10000  full      myri10ge0
bnx2         Ethernet             down       0      unknown   bnx2
bnx0         Ethernet             up         1000   full      bnx0
bnx1         Ethernet             down       0      unknown   bnx1
bnx3         Ethernet             down       0      unknown   bnx3

To create an aggregate device with two links (myri10ge0 and myri10ge1) in LACP mode (-L active) with and L2 failover policy (Determines the outgoing link by hashing the MAC (L2) header of each packet), run:

1
dladm create-aggr -l myri10ge0 -l myri10ge1 -L active -P L2 aggr1

You can use dladm show-aggr to see the current state:

1
2
3
root@Server47:~# dladm show-aggr
LINK            POLICY   ADDRPOLICY           LACPACTIVITY  LACPTIMER   FLAGS
aggr1           L2       auto                 active        short       -----

Next, create an interface aggr1:

1
2
3
4
5
6
root@Server47:~# ipadm create-if aggr1
root@Server47:~# ipadm show-if
IFNAME     STATE    CURRENT      PERSISTENT
lo0        ok       -m-v------46 ---
bnx0       ok       bm--------46 -46
aggr1      down     bm--------46 -46

You should now see that the LACP link is established on the layer 2 switch:

1
2
3
4
5
6
S4810(conf)#do show interfaces port-channel 9 brief
Codes: L - LACP Port-channel
    LAG  Mode  Status       Uptime      Ports         
L   9    L2L3  up           00:00:00    Te 0/32    (Up)
                                        Te 0/33    (Up)

The last thing left to do is to create an IP address on top of the aggr1 interface:

1
root@Server47:~# ipadm create-addr -T static -a 10.11.20.6/16 aggr1/v4

Again, depending on your topology, you might want to add/edit you default route to go over the aggragate interface.