Huawei S2326TP-EI. MVR

Ворог в пилюці, скотиняка.


Зразу кажу, ця конфігурація базується на user-vlans, ага.

1. Глобально дозволяємо igmp-snooping:
[huawei] igmp-snooping enable

2. Створюємо user vlans і дозволяємо igmp-snooping у них:
[huawei] vlan 2101
[huawei-vlan2101] description user_2101
[huawei-vlan2101] igmp-snooping enable
[huawei-vlan2101] quit

3. Створюємо multicast-groups, розбиваємо їх на multicast-lists, які прив’язуємо до multicast-profile:
[huawei] btv

4. Створюємо multicast vlan і дозволяємо igmp-snooping у ньому, після чого додаємо user vlans:
[huawei] vlan 35
[huawei-vlan35] description IPTV_vlan
[huawei-vlan35] igmp-snooping enable
[huawei-vlan35] multicast-vlan enable
[huawei-vlan35] multicast-vlan user-vlan 2101 to 2124
[huawei-vlan35] attach multicast-profile IPTV-P1
[huawei-vlan35] quit

5. Конфігуруємо інтерфейси в hybrid-режимі:
[huawei] interface ethernet0/0/1
[huawei-Ethernet0/0/1] port hybrid pvid vlan 2101
[huawei-Ethernet0/0/1] port hybrid untagged vlan 35 2101
[huawei-Ethernet0/0/1] quit

(!) Якщо інтерфейси уже в access-режимі, то спочатку потрібно зробити слідуюче:
[huawei-Ethernet0/0/1] port default vlan 1
[huawei-Ethernet0/0/1] port link-type hybrid

6. Не забуваємо прийняти всі влани на гігабітних портах!

7. Перевіряємо роботу:
[huawei] display l2-multicast forwarding-table vlan 35


Huawei. Basic commands

Свят свят свят. Спаси, о Сотона, від цього горя.


Reset to defaults:
1. Підключаємося через minicom і вмикаємо світчару в мережу;
2. Чекаємо на рядок: Press Ctrl+B to enter BOOTROM menu
3. Жмемо вказані клавіші;
4. Вводимо пароль “www.huawei.com” (може бути “huawei”);
5. Бачимо “BOOTROM MENU”;
6. Вводимо цифру, яка відповідає пункту Enter filesystem submenu;
7. Бачимо “FILESYSTEM SUBMENU”;
8. Вводимо цифру, яка відповідає пункту Delete file from Flash;
9. Бачимо список файлів в пам’яті:
10. Копіюємо назву свого .cfg файла:
11. Вставляємо у рядок: Please choose the file you want to delete:, жмемо “Y”;
12. Знову бачимо “FILESYSTEM SUBMENU”;
13. Вводимо цифру, яка відповідає пункту Return to main menu;
14. Знову бачимо “BOOTROM MENU”;
15. Вводимо цифру, яка відповідає пункту Reboot;

Пишуть люди


Download configuration via tftp:
1. Підключаємося через minicom і вмикаємо світчару в мережу;
2. Чекаємо повного завантаження;
3. Вводимо пароль 1234 і підтверджуємо його;
4. Створюємо інтерфейс в дефолтному влані:
sys
interface vlanif 1
ip address 192.168.1.3 255.255.255.0
quit
quit

5. Завантажуємо файл з конфігом:
tftp 192.168.1.2 get huawei.cfg
6. Вказуємо наш файл для завантаження:
startup saved-configuration huawei.cfg
7. Перезавантажуємо комутатор:
reboot
(!) При перезавантаженні буде запит на збереження поточних налаштувань у файл конфігурації, потрібно вибрати N, щоб відмовитися.
Потім вибираємо Y, щоб продовжити перезавантаження.


Налаштування порта:
interface Ethernet0/0/1
mac-limit maximum 1 alarm disable
loopback-detect enable
undo ntdp enable
undo ndp enable
broadcast-suppression 33


Вмикаємо діапазон портів:
port-group 1
group-member ethernet 0/0/1 to ethernet 0/0/24
undo shutdown


Admin-user:
[Huawei]user-interface vty 0 4
[Huawei -ui-vty0-4]authentication-mode aaa
[Huawei]aaa //enter into AAA view
[Huawei -aaa]local-user admin123 password cipher admin123 //configure local user admin123, the password is admin123
[Quidway-aaa]local-user admin123 privilege level 15 //configure user admin123 level is 3
[Quidway-aaa]local-user admin123 service-type telnet // configure user admin123 service type telnet


SNMP:

1. Дивимося статус агента:
display snmp-agent sys-info

2. Підключаємо SNMP v2 і відключаємо v3:
snmp-agent sys-info version v2c
undo snmp-agent sys-info version v3

3. Вказуємо community:
snmp-agent community write ******

4. Контактні дані:
snmp-agent sys-info contact ***@***.**
snmp-agent sys-info location ******


Serial number:
display elabel


Порт
Помилки на порту:
SW1-Q2326> display interface-statistics Ethernet 0/0/1

Очищаємо помилки:
SW1-Q2326> reset counters interface Ethernet 0/0/1


Налаштування часу

Спочатку потрібно вийти з режиму конфігурації:
quit

Поточний час:
display clock

Встановити часовий пояс:
clock timezone Kyiv add 2

Налаштування літнього часу:
clock daylight-saving-time Kyiv repeating 03:00 last sat Mar 04:00 last sat Oct 1


Прошивка
Настройка