Cisco. Basic commands

Створити користувача:
username admin secret 1234
enable secret admin
line vty 0 4
logging synchronous
login local

Установка пароля для консолі:
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login

Установка пароля для telnet:
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login

Видалення консольного пароля:
router(config)#line console 0
router(config-line)#no login
router(config-line)#no password

Видалення пароля Secret:
router(config)#no enable secret

Перевірка параметра Register:
router#show version

Задание адреса-маски и административное включение интерфейса:
R1(config)#interface Serial0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0

Административное выключение интерфейса маршрутизатора:
router(config)#int s0/0
router(config-if)#shutdown

Включение интерфейса Serial:
router#configure terminal
router(config)#interface s0/0
router(config-if)#no shutdown

Установка тактовой частоты для интерфейса Serial:
router(config-if)#clock rate 64000

Проверка интерфейса Serial:
router(config)#show interfaces s0/0

Добавить статическую запись в таблицу маршрутизации:
Router(config)#ip route 10.10.10.0 255.255.255.0 {ip-address | exit-interface }

Посмотреть таблицу маршрутизации:
R1#show ip route

Посмотреть интерфейсы:
R1#show interfaces

Посмотреть интерфейсы и их статистику в табличном виде:
R1#show ip interface brief

Посмотреть соседей устройства:
Router#show cdp neighbors
Router#show cdp neighbors detail

Глобальное выключение CDP (cisco discovery protocol):
Router(config)#no cdp run

Выключение CDP (cisco discovery protocol) на интерфейсе:
Router(config-if)#no cdp enable

Статус DTE/DCE:
router#show controllers s0/0

Сохранение конфигурации:
router#copy running-config startup-config

Загрузка файла (например IOS) с TFTP сервера:
R#copy tftp flash:

Резервное копирование Startup конфига на TFTP:
router#copy startup-config tftp

Сохранение Running конфига:
router#write memory
router#copy run st

Удаление конфигурации NVRAM
router#write erase

Проверка конфигурации NVRAM
router#show startup-config

Посмотреть таблицу MAC адресов свитча
show mac-address-table

Статически прописать MAC адрес в таблицу адресов свитча
#mac-address-table static MAC address vlan {1-4096, ALL} interface interface-id command

Создать VLAN
S1(config)#vlan 20
S1(config-vlan)#name students

Создаем интерфейс для управления VLAN
S1(config)#interface vlan 20
S1(config-if)#ip address 10.2.2.1 255.255.255.0
S1(config-if)#no shutdown

Назначить порт для доступа к VLAN
S1(config)#interface fa0/18
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20

Назначить порт для транка Cisco Dynamic Trunking protocol
S1(config)#interface fa0/18
или S1(config-if)#switchport mode trunk
ли S1(config-if)#switchport mode dynamic auto
или S1(config-if)#switchport mode dynamic desirable
или S1(config-if)#switchport mode nonegotiate

какие vlan пропускать через trunk
S1(config-if)#switchport trunk allowed vlan 18 (можно указывать диапазоны или all)

Переключиться обратно из trunk в режим доступа
S1(config-if)#no switchport trunk allowed vlan
S1(config-if)#no switchport trunk native vlan
S1(config-if)#switchport mode access

Разрешить трафик местного (native) VLAN через порт транка
S1(config)#interface fa0/18
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk native vlan 18
S1#show interfaces fa0/18 switchport

Посмотреть статистику VLAN
или show vlan brief
или show vlan id 20
или show vlan name students
или show vlan summary

Посмотреть статистику портов свитча
show interfaces vlan 20
show interfaces fa0/18 switchport

Назначить шлюз по умолчанию
S1(config)#ip default gateway 1.2.3.4

Включить протокол динамической маршрутизации
R1(config)#router протокол (rip, eigrp и т.д.)
R1(config-router)#network network_number [wildcard_mask]
R1(config-if)#bandwidth 64

R1(config-router)#passive-interface s 0/0/0 Выключить динамическую маршрутизацию на интерфейсе
или
R1(config-router)#passive-interface default Выключить динамическую маршрутизацию на всех интерфейсах
а потом на некоторых включить:
R1(config-router)#no passive-interface s 0/0/0


Всякі команди


Alcatel. Basic commands

Порт
Показати всі:
show interfaces port

Показати конкретний:
show interfaces 1/1 port

Розширений статус:
show interfaces 1/1

Вкл/викл:
interfaces 1/1 admin up/down

Підписати:
interfaces 1/1 alias dl:new:port:alias

Подивитися маки:
show mac-address-table 1/1

Помилки на порту:
show interfaces 1/1 counters errors

Очистити статистику:
interfaces 1/1 no l2 statistics


VLAN
Показати всі:
show vlan

Показати конкретний:
show vlan 111

Показати влани на порту:
show vlan port 1/1

Створити:
vlan 111 1x1 stp disable flat stp disable name new_vlan

Видалити:
no vlan 111

Видати в тегованому вигляді:
vlan 111 802.1q 1/1

Прибрати тегований:
vlan 111 no 802.1q 1/1

Видати в нетегованому вигляді:
vlan 111 port default 1/1

Прибрати нетегований:
vlan 111 no port default 1/1

Вкл/викл:
vlan 111 enable/disable

Подивитися маки у влані:
show mac-address-table 111

Вказати мак наса для влана на аплінкові:
mac-address-table 11:11:11:11:11:11 1/25 111


IP
Список IP комутатора:
show ip interface

Встановити IP для менеджмента:
ip interface Management address 111.111.111.111 mask 255.255.255.0 vlan 111 no forward


SNMP:
Запустити сервіс:
ip service snmp

Дозволити підключення за допомогою локальних паролів:
aaa authentication snmp "local"

Встановити пароль:
snmp security no security
user snmp password qwerty123 READ-ONLY all no auth
snmp community map qwerty123 user "snmp" on

Дізнатися адресу сервера, на який комутатор відсилає трапи:
show snmp station

Вказати, куди відсилати трапи:
snmp authentication trap disable
snmp station A.B.C.D 162 "snmp" v2 enable


NTP
Запустити службу:
ntp client enable

Вказати сервер часу:
ntp server 111.111.111.111 prefer

Встановити часовий пояс:
system timezone eet
system daylight savings time enable


Stacking
Статус стека:
show stack topology

Перейменувати слот 2 в слот 4:
stack set slot 2 saved-slot 4

Перевести комутатор 6850Е в режим 6850:
stack set slot 1 saved-mode os6850


System
Якщо на виникає помилка нехватки пам’яті – видалити файл K2diag.img в папках working і certified.

Подивитися конфіг:
show configuration snapshot

Подивитися навантаження на процесор:
show health all cpu

Логи:
show log swlog

Активні служби:
show ip service

Створити користувача:
user admin password qwerty read-write all

Подивитися мак комутатора:
show chassis

Перезавантаження:
reload working no rollback-timeout

Зберегти конфіг:
write memory

Скопіювати конфігурацію в резервний конфіг і синхронізувати стек:
copy working certified flash-synchro


Хабр пише
Базові команди при роботі з Алкатель
Базові команди при роботі з Алкатель #2
Базові команди при роботі з Алкатель #3